ADICON Support Forum Applied Digital, Inc.
Page 1 of 1 1
Topic Options
#15782 - 05/16/06 05:51 AM Leo II has lost comms
Spadey Offline
newbie


Registered: 05/24/04
Posts: 16
My once happily running Leo II has gone quiet.

The Leo itself runs fine - it will switch between screens et etc, but I get no control happening. The line to the X10 interface is fine, but I'm not sure about the interface itself (and without a spare I can't swap it out).

The three LED's on the RHS do the following:

The lower green LED appears to be on continuously, and occaisionally appears to blink very rapidly for a brief moment.

The middle red on is on - I have no ADICON bus modules (at present) attached

The top green LED blinks 4 times, rests blinks 4 times etc.

I also am hving trouble connecting via PC to it - it has always been "fragile" in the to PC comms dept. Sometimes it will be fine, others it just won't connect and the next day will be fine again - somewhat frustrating!

I've cycled it and also reloaded the exec (I did manage to talk to it earlier, but now it won't) and the program, but to no avail.

Any help/suggestions/solutions wuold be great

A

Top
#15783 - 05/16/06 10:04 AM Re: Leo II has lost comms [Re: Spadey]
Guy Lavoie Administrator Offline
Beyond All Hope
*****

Registered: 12/21/02
Posts: 6548
Loc: Montreal, QC, Canada
Its not clear, but is the X10 working ok but not the comms to the PC?

It looks like the RS-232 chip might have gone bad. This is a MAX202 or equivalent. If the X10 also stopped working at the same time, then it could be something else altogether, like a corrupted flash memory. Try to explain the problems in a bit more detail. Also, have you tried it with C-Max on another PC as a test?
_________________________
"If you don't know what you're doing, do it neatly..."

Top
#15784 - 05/16/06 06:34 PM Re: Leo II has lost comms [Re: Guy Lavoie]
Spadey Offline
newbie


Registered: 05/24/04
Posts: 16
Guy

Now I am more confused. I went to bed last night (having turned off all the lights manually, except one I can't).

The program I run in the Leo does a global "All lights off" for all house codes at 11:30 pm.

This worked perfectly, and now this morning the Leo controls (X10) everything fine. Does the Leo do a memory purge type reset late in the evenings?

Also, I thought it could be a code problem. I have a wireless controller in the system and I use it to send X10 out - and the Leo responds.

Basically it is on code A and if I send an A1/ON message (ie pressing the remote ON button)the Leo senses it and turns on what I want. What I was thinking was, when I checked the X10 last night (when I could talk to it) A1 was on i the table - would this possibly lock up the program by constantly trying to turn on light that should respond (via the Leo) to that signal? I have been running this for a couple of weeks with no dramas, but it may be a problem...

I haven't tried connecting via CMax (had to go to work...)but I reckon it will talk happily to me today...

A

Top
Page 1 of 1 1


Moderator:  Dan Smith, Monte G, ADI Tech Support, Guy Lavoie 
Hop to:
Who's Online
0 registered and 56 anonymous users online.
Recent Posts
Comms Retry Error
by HDTVPete
09/18/17 04:04 PM
Cmax Message: Failed to set data for a 'delay'
by HDTVPete
09/16/17 04:36 PM
Shout Box

Newest Members
brigiel, vevevie, zhutree, 416, saiqul
3003 Registered Users
Forum Stats
3003 Members
19 Forums
4001 Topics
23433 Posts

Max Online: 132 @ 11/13/16 10:07 AM
September
Su M Tu W Th F Sa
1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30