ADICON Support Forum Applied Digital, Inc.
Page 1 of 1 1
Topic Options
#19446 - 02/04/08 06:19 PM Trouble With Vista
Mark Offline
newbie


Registered: 09/28/04
Posts: 4
Loc: San Diego
I have created a program in VB6, that sends commands to the Ocelot.

It has been working great, but I just tried the same program on a Vista PC. When I try to run the program, I get an error MSCOMM32.ocx or one of its dependencies not correctly registered, a file is missing or invalid.

I tried to copy mscomm32.ocx into windows\system and windows\system32, but no luck.

Would appreciate any suggestions!

Mark@A1Productivity.com

Top
#19447 - 02/04/08 06:31 PM Re: Trouble With Vista [Re: Mark]
Guy Lavoie Administrator Offline
Beyond All Hope
*****

Registered: 12/21/02
Posts: 6548
Loc: Montreal, QC, Canada
Try this: open a command line window and try this command:

regsvr32 "C:\Windows\System32\mscomm32.ocx"

If you get a message saying that it registered correctly, try your VB program again.
_________________________
"If you don't know what you're doing, do it neatly..."

Top
#19449 - 02/04/08 08:04 PM Re: Trouble With Vista [Re: Guy Lavoie]
Mark Offline
newbie


Registered: 09/28/04
Posts: 4
Loc: San Diego
I tried that, and I also tried to uninstall /u and then reinstall, but it still does not work.

It would seem there is some "rights" issue, but it is a laptop, and I am listed as the supervisor, so I can not figure out why it won't register.

Thank you for your help!

Mark

Top
#19450 - 02/04/08 08:54 PM Re: Trouble With Vista [Re: Mark]
Mark Offline
newbie


Registered: 09/28/04
Posts: 4
Loc: San Diego
Guy,

I tried everything over and over, then I thought, what if the mscomm32.ocx file is bad?

Deleted the file off the Vista PC, copied on the file off my XP machine I knew was working, and that did the trick!

Thanks for your help!

You stay warm up there,

Mark

Top
Page 1 of 1 1


Moderator:  Dan Smith, Monte G, ADI Tech Support, Guy Lavoie 
Hop to:
Who's Online
0 registered and 65 anonymous users online.
Recent Posts
Secu16 inputs not working correctly
by ADI Tech Support
10/03/17 06:01 AM
Ocelot Battery
by ADI Tech Support
09/22/17 07:38 AM
Shout Box

Newest Members
brigiel, vevevie, zhutree, 416, saiqul
3003 Registered Users
Forum Stats
3003 Members
19 Forums
4003 Topics
23440 Posts

Max Online: 132 @ 11/13/16 10:07 AM
October
Su M Tu W Th F Sa
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31