ADICON Support Forum Applied Digital, Inc.
Page 1 of 1 1
Topic Options
#13091 - 02/06/05 06:26 PM xalib and FreeBSD 5.3
drich Offline
newbie


Registered: 05/07/03
Posts: 15
Loc: San Jose, CA
Has anyone gotten xalib/cpuxad working under FreeBSD 5.3? I've managed to get it to compile with a little bit of work (diffs below), but cannot get it to run. It seg faults almost immediately, and since it uses the linux compatibility libraries I don't get anything useful from gdb.

Any ideas?

Here are my diffs to get it to build (FreeBSD doesn't have malloc.h, it uses stdlib.h; and doesn't have OLCUC in the tty flags):
[CODE]--- lib/serial.c.orig Sun Feb 6 19:19:49 2005
+++ lib/serial.c Sun Feb 6 19:18:45 2005
@@ -88,7 +88,9 @@
t.c_iflag |= (IGNBRK|IXANY|IGNPAR); /* ignore break and parity */

t.c_oflag &= ~(
+#ifndef __FreeBSD__
OLCUC | /* no lowercase -> upper */
+#endif
OCRNL | /* no output cr->nl */
ONLCR | /* no output nl->cr */
OPOST ); /* no post-processing */
--- server/cpuxad.c.orig Sun Feb 6 19:19:33 2005
+++ server/cpuxad.c Sun Feb 6 19:19:21 2005
@@ -9,7 +9,9 @@
#include
#include
#include
+#ifndef __FreeBSD__
#include
+#endif
#include
#include
#include [/CODE]
_________________________
Dan Rich
http://www.employees.org/~drich/

Top
#13092 - 02/13/05 02:40 PM Re: xalib and FreeBSD 5.3
Mark Day Offline
newbie


Registered: 02/12/05
Posts: 2
Hey Drich,
If you're using the 3.08 executive, xalib
needs a few patches to deal. I've been hacking
around a bit with it again and it seems to be
working here. I'd like to release another tarball
with the patches Neil has done as well as anything
you might add for FreeBSD. I believe David Norwood
had a few patches for Leviton if Im not mistaken,
I'd like to hear from him as well as to whether he
has any more to add. Write back here, good to see
you're still about.
_________________________
Mark

Top
#22055 - 08/24/10 01:55 AM Re: xalib and FreeBSD 5.3 [Re: Mark Day]
bvnoldguy Offline
journeyman


Registered: 07/20/10
Posts: 50
Where can I get the CPU-XA internal addresses that are compatible with C-MAX 2.x? I would like to upgrade my Python version of XPUXA
Top
Page 1 of 1 1


Moderator:  Dan Smith, Monte G, ADI Tech Support, Guy Lavoie 
Hop to:
Who's Online
0 registered and 46 anonymous users online.
Recent Posts
Shout Box

Newest Members
brigiel, vevevie, zhutree, 416, saiqul
3003 Registered Users
Forum Stats
3003 Members
19 Forums
3998 Topics
23424 Posts

Max Online: 132 @ 11/13/16 10:07 AM
April
Su M Tu W Th F Sa
1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30